> For the complete documentation index, see [llms.txt](https://docs.enercalc.com/llms.txt). Markdown versions of documentation pages are available by appending `.md` to page URLs; this page is available as [Markdown](https://docs.enercalc.com/e3d-training-manual/building-the-model/general-modeling-theory/constructing-model-geometry/adding-nodes.md).

# Adding Nodes

How to add nodes to a model graphically on the grid or by entering coordinates in the Nodes table.

Nodes can be added to a model in at least a few ways.

**Adding Nodes Graphically:**

With a grid displayed on the screen, click **Create > Nodes**. Notice that the cursor changes to a pen.

![](https://3750289988-files.gitbook.io/~/files/v0/b/gitbook-x-prod.appspot.com/o/spaces%2FlRZtG5Ynp58kYzLHYbR7%2Fuploads%2Fgit-blob-b8f40315250f43d455a79438f4f768414b5e8d6a%2FCursor%20on%20grid.jpg?alt=media)

Hover over the grid and notice the triangle that tracks the pen movements and automatically snaps to grids. Note that the Status Bar displays the X, Y and Z coordinates of every location where the cursor snaps to the grid. This is useful for orientation.

To add a node, just click anywhere on the grid and then move the cursor to see that a dark, bold dot remains at the click location.

If node numbers are not currently displayed, they can be toggled on by clicking **View > Display Options > Node Display Options > Node Number**. Notice that there is also an icon on the Quick Access Toolbar that makes this process possible without leaving the Create tab: ![](https://3750289988-files.gitbook.io/~/files/v0/b/gitbook-x-prod.appspot.com/o/spaces%2FlRZtG5Ynp58kYzLHYbR7%2Fuploads%2Fgit-blob-d1d461bd8b431755d1c424f8172406a02e7e2885%2FNode%20Display%20Options%20Button.jpg?alt=media)

Click in a few more locations to add some additional nodes.

Click **View > Query**, and then click on any node to display the *Nodal Info* dialog. At this time, the dialog will list the coordinates of the selected node, but it won't have much additional info, because no loads have been assigned and no analysis results are available. Keep this Query function function in mind, because it can be an extremely useful way to get info about a model entity at any time.

Close the *Nodal Info* dialog if it is still open.

**Adding Nodes with the Node Data Table:**

Click **Tables > Nodes** to open the *Nodes* table.

Notice that the table lists all nodes that have been defined, and it displays their coordinates.

To add another node in the current model, use the New Rows button in the lower left corner of the *Nodes* table to add one new row. Then enter the desired coordinates for the new node, and then click OK.

Notice that the *Nodes* table does not constrain nodes to the grid increments, so it can be useful for entering nodes with coordinates that aren't nice and even. The table can also be a convenient way to move an existing node by editing its coordinates, and we will demonstrate that in the section on Editing Model Geometry.

{% hint style="info" %}
Note: The methods of adding nodes that we have discussed here can be thought of as the "explicit" methods. There are also methods of creating new nodes that can be thought of as the "implicit" methods, such as generating nodes in a pattern or automatically creating nodes at member intersections or splitting members or duplicating members. But we will cover all of those topics shortly.
{% endhint %}


---

# Agent Instructions
This documentation is published with GitBook. GitBook is the documentation platform designed so that both humans and AI agents can read, navigate, and reason over technical content effectively. Learn more at gitbook.com.

## Querying This Documentation
If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter, and the optional `goal` query parameter:

```
GET https://docs.enercalc.com/e3d-training-manual/building-the-model/general-modeling-theory/constructing-model-geometry/adding-nodes.md?ask=<question>&goal=<endgoal>
```

`ask` is the immediate question: it should be specific, self-contained, and written in natural language.
`goal` is optional and describes the broader end goal you are ultimately trying to accomplish on behalf of the user. GitBook uses it to tailor the answer towards what is most useful for that goal.

The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
